added test for url_encode
[psensor.git] / tests / Makefile.am
index 1acf104..aa957a0 100644 (file)
@@ -2,4 +2,10 @@ check-local: checkpatch.pl
        find $(top_srcdir)/src -name \*.c -exec $(srcdir)/checkpatch.pl -q --no-tree  -emacs -f {} \;
        find $(top_srcdir)/src -name \*.h -exec $(srcdir)/checkpatch.pl -q --no-tree  -emacs -f {} \;
 
-EXTRA_DIST = checkpatch.pl 
\ No newline at end of file
+EXTRA_DIST = checkpatch.pl 
+
+check_PROGRAMS = test-url-encode
+test_url_encode_SOURCES = test_url_encode.c
+test_url_encode_LDADD = ../src/lib/libpsensor.a
+
+TESTS = test-url-encode
\ No newline at end of file