Fixed restoration of the panel divider position.
[psensor.git] / tests / Makefile.am
index aefec3f..5bf8b1f 100644 (file)
@@ -4,7 +4,10 @@ check-local: checkpatch.pl
 
 DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
 
-EXTRA_DIST = checkpatch.pl data test-io-dir-list.sh
+EXTRA_DIST = checkpatch.pl \
+       spelling.txt \
+       test-cppcheck.sh \
+       test-io-dir-list.sh
 
 check_PROGRAMS = test-io-dir-list \
        test-psensor-type-to-unit-str \
@@ -12,7 +15,7 @@ check_PROGRAMS = test-io-dir-list \
        test-url-encode \
        test-url-normalize
 
-AM_CPPFLAGS = -pedantic -Werror
+AM_CPPFLAGS = -Wall -Werror
 
 LIBS += ../src/lib/libpsensor.a \
        $(SENSORS_LIBS)
@@ -27,7 +30,9 @@ endif
 
 test_io_dir_list_SOURCES = test_io_dir_list.c
 test_psensor_type_to_unit_str_SOURCES = test_psensor_type_to_unit_str.c
+test_psensor_type_to_unit_str_CFLAGS = -I$(top_srcdir)/src/lib
 test_psensor_value_to_str_SOURCES = test_psensor_value_to_str.c
+test_psensor_value_to_str_CFLAGS = -I$(top_srcdir)/src/lib
 test_url_encode_SOURCES = test_url_encode.c
 test_url_normalize_SOURCES = test_url_normalize.c
 
@@ -36,3 +41,7 @@ TESTS = test-io-dir-list.sh \
        test-psensor-value-to-str \
        test-url-encode \
        test-url-normalize
+
+if CPPCHECK
+TESTS += test-cppcheck.sh
+endif