Fixed restoration of the panel divider position.
[psensor.git] / tests / Makefile.am
index 575e0e8..5bf8b1f 100644 (file)
@@ -4,14 +4,18 @@ check-local: checkpatch.pl
 
 DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
 
-EXTRA_DIST = checkpatch.pl data test-io-dir-list.sh
+EXTRA_DIST = checkpatch.pl \
+       spelling.txt \
+       test-cppcheck.sh \
+       test-io-dir-list.sh
 
 check_PROGRAMS = test-io-dir-list \
        test-psensor-type-to-unit-str \
+       test-psensor-value-to-str \
        test-url-encode \
        test-url-normalize
 
-AM_CPPFLAGS = -pedantic -Werror
+AM_CPPFLAGS = -Wall -Werror
 
 LIBS += ../src/lib/libpsensor.a \
        $(SENSORS_LIBS)
@@ -24,15 +28,20 @@ if GTOP
 LIBS += $(GTOP_LIBS)
 endif
 
+test_io_dir_list_SOURCES = test_io_dir_list.c
 test_psensor_type_to_unit_str_SOURCES = test_psensor_type_to_unit_str.c
-
+test_psensor_type_to_unit_str_CFLAGS = -I$(top_srcdir)/src/lib
+test_psensor_value_to_str_SOURCES = test_psensor_value_to_str.c
+test_psensor_value_to_str_CFLAGS = -I$(top_srcdir)/src/lib
 test_url_encode_SOURCES = test_url_encode.c
-
 test_url_normalize_SOURCES = test_url_normalize.c
 
-test_io_dir_list_SOURCES = test_io_dir_list.c
-
-TESTS = test-psensor-type-to-unit-str \
+TESTS = test-io-dir-list.sh \
+       test-psensor-type-to-unit-str \
+       test-psensor-value-to-str \
        test-url-encode \
-       test-url-normalize \
-       test-io-dir-list.sh
\ No newline at end of file
+       test-url-normalize
+
+if CPPCHECK
+TESTS += test-cppcheck.sh
+endif