don't use -pedantic when compiling src/server
[psensor.git] / src / lib / Makefile.am
index 511fe34..0e49961 100644 (file)
@@ -1,14 +1,27 @@
 noinst_LIBRARIES = libpsensor.a
 
-libpsensor_a_CFLAGS = -pedantic -Werror
-
 libpsensor_a_SOURCES = \
+       amd.h \
+       cpu.h \
        measure.h measure.c \
        color.h color.c \
+       log.h log.c \
        psensor.h psensor.c\
-       hdd.h hdd.c\
+       hdd.h\
        nvidia.h \
-       lmsensor.h lmsensor.c
+       lmsensor.h lmsensor.c \
+       pio.h pio.c \
+       url.c url.h
+
+AM_CPPFLAGS = -Wall -Werror
+
+if ATASMART
+libpsensor_a_SOURCES += hdd_atasmart.c
+LIBS += $(ATASMART_LIBS)
+AM_CPPFLAGS += $(ATASMART_CFLAGS)
+else
+libpsensor_a_SOURCES += hdd_hddtemp.c
+endif
 
 if NVIDIA
 libpsensor_a_SOURCES += nvidia.c
@@ -16,5 +29,23 @@ endif
 
 if LIBATIADL
 LIBS += $(LIBATIADL_LIBS)
-AM_CPPFLAGS = $(LIBATIADL_CFLAGS)
-endif
\ No newline at end of file
+AM_CPPFLAGS += $(LIBATIADL_CFLAGS)
+libpsensor_a_SOURCES += amd.c
+endif
+
+if GTOP
+libpsensor_a_SOURCES += cpu.c
+LIBS += $(GTOP_LIBS)
+AM_CPPFLAGS += $(GTOP_CFLAGS)
+endif
+
+if JSON
+libpsensor_a_SOURCES += psensor_json.h psensor_json.c
+LIBS += $(JSON_LIBS)
+AM_CPPFLAGS += $(JSON_CFLAGS)
+endif
+
+EXTRA_DIST=$(libpsensor_a_SOURCES) \
+       amd.c \
+       cpu.c \
+       nvidia.c
\ No newline at end of file