next release will be 0.7
[psensor.git] / src / Makefile.am
index bde5a54..e21d7fc 100644 (file)
@@ -1,18 +1,15 @@
-SUBDIRS = plib lib unity glade
+SUBDIRS = lib glade
 
 AM_LDFLAGS = -Wl,--as-needed 
 
-if JSON
-SUBDIRS += libpsensor_json
-endif
-
 if LIBMICROHTTPD
 if JSON
 SUBDIRS += server
 endif
 endif
 
-AM_CPPFLAGS = -Wall -pedantic -Werror -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
+# -no-deprecated-declarations to avoid some glib deprecation warnings
+AM_CPPFLAGS = -Wno-deprecated-declarations -Wall -Werror -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
        -I$(top_srcdir)/src/lib \
        -I$(top_srcdir)/src/unity \
        $(GTK_CFLAGS)\
@@ -22,7 +19,6 @@ AM_CPPFLAGS = -Wall -pedantic -Werror -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
 DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
 
 LIBS = \
-       plib/libplib.a \
        lib/libpsensor.a \
        $(GTK_LIBS)\
        $(GCONF_LIBS)\
@@ -35,11 +31,18 @@ psensor_SOURCES = \
        graph.h graph.c \
        main.c \
        ui.h ui.c \
+       ui_appindicator.h \
        ui_color.h ui_color.c \
        ui_graph.h ui_graph.c \
        ui_pref.h ui_pref.c \
        ui_sensorlist.h ui_sensorlist.c \
-       ui_sensorpref.h ui_sensorpref.c
+       ui_sensorpref.h ui_sensorpref.c \
+       ui_status.h ui_status.c
+
+if GTOP
+AM_CPPFLAGS += $(GTOP_CFLAGS)
+LIBS += $(GTOP_LIBS)
+endif
 
 if LIBNOTIFY
 psensor_SOURCES += ui_notify.h ui_notify.c
@@ -48,7 +51,7 @@ AM_CPPFLAGS += $(LIBNOTIFY_CFLAGS)
 endif
 
 if APPINDICATOR 
-psensor_SOURCES += ui_appindicator.h ui_appindicator.
+psensor_SOURCES += ui_appindicator.c 
 LIBS +=        $(APPINDICATOR_LIBS)
 AM_CPPFLAGS += $(APPINDICATOR_CFLAGS)
 endif
@@ -58,14 +61,25 @@ AM_CPPFLAGS += $(NVIDIA_CFLAGS)
 LIBS +=  $(NVIDIA_LIBS)
 endif
 
+if LIBATIADL
+AM_CPPFLAGS += $(LIBATIADL_CFLAGS)
+LIBS += $(LIBATIADL_LIBS)
+endif
+
+if ATASMART
+AM_CPPFLAGS += $(ATASMART_CFLAGS)
+LIBS += $(ATASMART_LIBS)
+endif
+
 if UNITY
+psensor_SOURCES += ui_unity.h ui_unity.c
 AM_CPPFLAGS += $(UNITY_CFLAGS)
-LIBS += unity/libpsensor_unity.a $(UNITY_LIBS) 
+LIBS += $(UNITY_LIBS) 
 endif
 
 if CURL
 if JSON
-psensor_SOURCES += rsensor.h rsensor.c plib/url.c plib/url.h
+psensor_SOURCES += rsensor.h rsensor.c
 LIBS += $(CURL_LIBS) $(JSON_LIBS)
 AM_CPPFLAGS += $(CURL_CFLAGS) $(JSON_CFLAGS)
 endif