removed lua support, monitoring page is now using jquery and json http requests
[psensor.git] / src / Makefile.am
index e567c83..bde5a54 100644 (file)
@@ -8,11 +8,9 @@ endif
 
 if LIBMICROHTTPD
 if JSON
-if LUA
 SUBDIRS += server
 endif
 endif
-endif
 
 AM_CPPFLAGS = -Wall -pedantic -Werror -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
        -I$(top_srcdir)/src/lib \
@@ -40,7 +38,8 @@ psensor_SOURCES = \
        ui_color.h ui_color.c \
        ui_graph.h ui_graph.c \
        ui_pref.h ui_pref.c \
-       ui_sensorlist.h ui_sensorlist.c 
+       ui_sensorlist.h ui_sensorlist.c \
+       ui_sensorpref.h ui_sensorpref.c
 
 if LIBNOTIFY
 psensor_SOURCES += ui_notify.h ui_notify.c
@@ -73,7 +72,7 @@ endif
 endif
 
 dist_man_MANS = psensor.1
-
+EXTRA_DIST = description.txt
 
 psensor.1: main.c $(top_srcdir)/configure.ac
        $(MAKE) $(AM_MAKEFLAGS) psensor$(EXEEXT)