Fixed restoration of the panel divider position.
[psensor.git] / src / Makefile.am
index 2e4bb19..8779d9e 100644 (file)
@@ -6,6 +6,7 @@ psensor_SOURCES = \
        graph.h graph.c \
        main.c \
        pxdg.h pxdg.c \
+       rsensor.h \
        ui.h ui.c \
        ui_appindicator.h \
        ui_color.h ui_color.c \
@@ -98,21 +99,23 @@ endif
 
 if CURL
 if JSON
-psensor_SOURCES += rsensor.h rsensor.c
+psensor_SOURCES += rsensor.c
 LIBS += $(CURL_LIBS) $(JSON_LIBS)
 AM_CPPFLAGS += $(CURL_CFLAGS) $(JSON_CFLAGS)
 endif
 endif
 
+if HELP2MAN
 psensor.1: main.c $(top_srcdir)/configure.ac
        $(MAKE) $(AM_MAKEFLAGS) psensor$(EXEEXT)
        help2man --include=description.txt -N --name="Temperature monitoring application" --output=psensor.1 ./psensor$(EXEEXT)
+endif
 
 gsettings_SCHEMAS=psensor.gschema.xml
 
 EXTRA_DIST = description.txt\
        $(gsettings_SCHEMAS)\
-       rsensor.h rsensor.c\
+       rsensor.c\
        ui_appindicator.c\
        ui_notify.c\
        ui_unity.c