avoid to fail on error due to deprecation of GtkStatusIcon
[psensor.git] / src / Makefile.am
index 2ee2568..7611095 100644 (file)
@@ -1,10 +1,7 @@
-SUBDIRS = lib unity glade
+SUBDIRS = lib glade
 
-AM_LDFLAGS = -Wl,--as-needed 
-
-if JSON
-SUBDIRS += libpsensor_json
-endif
+# -export-dynamic is need for defining handlers in the glade file.
+AM_LDFLAGS = -Wl,--as-needed -export-dynamic
 
 if LIBMICROHTTPD
 if JSON
@@ -12,11 +9,13 @@ SUBDIRS += server
 endif
 endif
 
-AM_CPPFLAGS = -Wall -pedantic -Werror -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
+AM_CPPFLAGS =-Wall \
+       -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
+       -DDATADIR=\""$(datadir)"\"\
+       -DPSENSOR_DESKTOP_FILE=\""psensor.desktop"\"\
        -I$(top_srcdir)/src/lib \
        -I$(top_srcdir)/src/unity \
        $(GTK_CFLAGS)\
-       $(GCONF_CFLAGS)\
        $(SENSORS_CFLAGS)
 
 DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
@@ -24,21 +23,32 @@ DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
 LIBS = \
        lib/libpsensor.a \
        $(GTK_LIBS)\
-       $(GCONF_LIBS)\
-       $(SENSORS_LIBS)
+       $(PTHREAD_LIBS)\
+       $(SENSORS_LIBS) -lm
 
+if GTK
+if X11
+if XEXT
 bin_PROGRAMS = psensor
+dist_man_MANS = psensor.1
+endif
+endif
+endif
+
 psensor_SOURCES = \
-       compat.h \
        cfg.h cfg.c \
+       notify_cmd.c notify_cmd.h \
        graph.h graph.c \
        main.c \
        ui.h ui.c \
+       ui_appindicator.h \
        ui_color.h ui_color.c \
        ui_graph.h ui_graph.c \
        ui_pref.h ui_pref.c \
        ui_sensorlist.h ui_sensorlist.c \
-       ui_sensorpref.h ui_sensorpref.c
+       ui_sensorpref.h ui_sensorpref.c \
+       ui_status.h ui_status.c \
+       pxdg.h pxdg.c
 
 if GTOP
 AM_CPPFLAGS += $(GTOP_CFLAGS)
@@ -52,24 +62,36 @@ AM_CPPFLAGS += $(LIBNOTIFY_CFLAGS)
 endif
 
 if APPINDICATOR 
-psensor_SOURCES += ui_appindicator.h ui_appindicator.
+psensor_SOURCES += ui_appindicator.c 
 LIBS +=        $(APPINDICATOR_LIBS)
 AM_CPPFLAGS += $(APPINDICATOR_CFLAGS)
 endif
 
 if NVIDIA
+if X11
 AM_CPPFLAGS += $(NVIDIA_CFLAGS)
 LIBS +=  $(NVIDIA_LIBS)
 endif
+endif
 
 if LIBATIADL
 AM_CPPFLAGS += $(LIBATIADL_CFLAGS)
 LIBS += $(LIBATIADL_LIBS)
 endif
 
+if ATASMART
+AM_CPPFLAGS += $(ATASMART_CFLAGS)
+LIBS += $(ATASMART_LIBS)
+endif
+
+if LIBUDISKS2
+LIBS += $(LIBUDISKS2_LIBS)
+endif
+
 if UNITY
+psensor_SOURCES += ui_unity.h ui_unity.c
 AM_CPPFLAGS += $(UNITY_CFLAGS)
-LIBS += unity/libpsensor_unity.a $(UNITY_LIBS) 
+LIBS += $(UNITY_LIBS) 
 endif
 
 if CURL
@@ -80,10 +102,11 @@ AM_CPPFLAGS += $(CURL_CFLAGS) $(JSON_CFLAGS)
 endif
 endif
 
-dist_man_MANS = psensor.1
-EXTRA_DIST = description.txt
-
 psensor.1: main.c $(top_srcdir)/configure.ac
        $(MAKE) $(AM_MAKEFLAGS) psensor$(EXEEXT)
        help2man --include=description.txt -N --name="Temperature monitoring application" --output=psensor.1 ./psensor$(EXEEXT)
 
+gsettings_SCHEMAS=psensor.gschema.xml
+EXTRA_DIST = description.txt $(gsettings_SCHEMAS)
+
+@GSETTINGS_RULES@