Workarounded LP #905893
[psensor.git] / src / Makefile.am
index 622d225..1cc4d74 100644 (file)
@@ -8,7 +8,8 @@ SUBDIRS += server
 endif
 endif
 
-AM_CPPFLAGS = -Wall -pedantic -Werror -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
+# -no-deprecated-declarations to avoid some glib deprecation warnings
+AM_CPPFLAGS = -Wno-deprecated-declarations -Wall -Werror -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
        -I$(top_srcdir)/src/lib \
        -I$(top_srcdir)/src/unity \
        $(GTK_CFLAGS)\