added fcts to handle autostart of psensor
[psensor.git] / src / Makefile.am
index c89c8a3..0f64275 100644 (file)
@@ -10,7 +10,9 @@ endif
 endif
 
 # -no-deprecated-declarations to avoid some glib deprecation warnings
-AM_CPPFLAGS = -Wno-deprecated-declarations -Wall -Werror -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
+AM_CPPFLAGS = -Wno-deprecated-declarations -Wall -Werror \
+       -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
+       -DDATADIR=\""$(datadir)"\"\
        -I$(top_srcdir)/src/lib \
        -I$(top_srcdir)/src/unity \
        $(GTK_CFLAGS)\
@@ -26,9 +28,20 @@ LIBS = \
        $(PTHREAD_LIBS)\
        $(SENSORS_LIBS)
 
+if GTK
+if X11
+if XEXT
+if GCONF
 bin_PROGRAMS = psensor
+dist_man_MANS = psensor.1
+endif
+endif
+endif
+endif
+
 psensor_SOURCES = \
        cfg.h cfg.c \
+       notify_cmd.c notify_cmd.h \
        graph.h graph.c \
        main.c \
        ui.h ui.c \
@@ -38,7 +51,8 @@ psensor_SOURCES = \
        ui_pref.h ui_pref.c \
        ui_sensorlist.h ui_sensorlist.c \
        ui_sensorpref.h ui_sensorpref.c \
-       ui_status.h ui_status.c
+       ui_status.h ui_status.c \
+       pxdg.h pxdg.c
 
 if GTOP
 AM_CPPFLAGS += $(GTOP_CFLAGS)
@@ -58,9 +72,11 @@ AM_CPPFLAGS += $(APPINDICATOR_CFLAGS)
 endif
 
 if NVIDIA
+if X11
 AM_CPPFLAGS += $(NVIDIA_CFLAGS)
 LIBS +=  $(NVIDIA_LIBS)
 endif
+endif
 
 if LIBATIADL
 AM_CPPFLAGS += $(LIBATIADL_CFLAGS)
@@ -86,11 +102,9 @@ AM_CPPFLAGS += $(CURL_CFLAGS) $(JSON_CFLAGS)
 endif
 endif
 
-dist_man_MANS = psensor.1
 EXTRA_DIST = description.txt psensor.schemas
 
-
-if GCONF_SCHEMAS_INSTALL
+if GCONF
 schemadir = $(GCONF_SCHEMA_FILE_DIR)
 schema_DATA = psensor.schemas