v0.0.6
[ppastats.git] / trunk / src / Makefile.am
diff --git a/trunk/src/Makefile.am b/trunk/src/Makefile.am
new file mode 100644 (file)
index 0000000..fb3ce06
--- /dev/null
@@ -0,0 +1,26 @@
+
+AM_CPPFLAGS = -Wall -std=gnu99 -Werror\
+        -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
+       $(CURL_CFLAGS) $(JSON_CFLAGS)
+
+LIBS += $(CURL_LIBS) $(JSON_LIBS)
+
+bin_PROGRAMS = ppastats
+ppastats_SOURCES = \
+       cache.h cache.c\
+       html.h html.c\
+       io.h io.c\
+       list.h list.c\
+       lp.h lp.c\
+       lp_json.h lp_json.c\
+       lp_ws.h lp_ws.c\
+       main.c\
+       ppastats.h ppastats.c
+
+dist_man_MANS = ppastats.1
+
+ppastats.1: main.c $(top_srcdir)/configure.ac
+       if ! test -z "$(HELP2MAN)"; then \
+        $(MAKE) $(AM_MAKEFLAGS) ppastats$(EXEEXT); \
+        help2man -N --name="PPA Statistics command line tool" --output=ppastats.1 ./ppastats$(EXEEXT); \
+       fi;