no way to avoid the typedef for supporting old json releases
[ppastats.git] / tests / Makefile.am
index c305cb9..0a5f3ef 100644 (file)
@@ -1,5 +1,17 @@
 check-local: checkpatch.pl
-       find $(top_srcdir)/src -name \*.c -exec $(srcdir)/checkpatch.pl -q --no-tree  -emacs -f {} \;
-       find $(top_srcdir)/src -name \*.h -exec $(srcdir)/checkpatch.pl -q --no-tree  -emacs -f {} \;
+       find $(top_srcdir)/src -name \*.c -exec $(srcdir)/checkpatch.pl --show-types -q --no-tree  -emacs -f {} \;
+       find $(top_srcdir)/src -name \*.h -exec $(srcdir)/checkpatch.pl --ignore NEW_TYPEDEFS --show-types -q --no-tree  -emacs -f {} \;
 
-EXTRA_DIST = checkpatch.pl 
+EXTRA_DIST = \
+       checkpatch.pl \
+       test_strrep.c
+
+check_PROGRAMS = test-strrep
+
+AM_CPPFLAGS = -pedantic -Werror
+
+test_strrep_SOURCES = \
+       test_strrep.c \
+       ../src/str.c
+
+TESTS = test-strrep