added string replace fct
[ppastats.git] / tests / Makefile.am
index 9753322..466b5be 100644 (file)
@@ -2,4 +2,16 @@ check-local: checkpatch.pl
        find $(top_srcdir)/src -name \*.c -exec $(srcdir)/checkpatch.pl --show-types -q --no-tree  -emacs -f {} \;
        find $(top_srcdir)/src -name \*.h -exec $(srcdir)/checkpatch.pl --show-types -q --no-tree  -emacs -f {} \;
 
-EXTRA_DIST = checkpatch.pl 
+EXTRA_DIST = \
+       checkpatch.pl \
+       test_strrep.c
+
+check_PROGRAMS = test-strrep
+
+AM_CPPFLAGS = -pedantic -Werror
+
+test_strrep_SOURCES = \
+       test_strrep.c \
+       ../src/str.c
+
+TESTS = test-strrep