Merge tag 'upstream/1.3.1'
[ppastats-pkg-ubuntu.git] / tests / Makefile.am
index a94900d..e80d69c 100644 (file)
@@ -8,8 +8,7 @@ EXTRA_DIST = \
        test_strrep.c \
        test_ptime.c
 
-TESTS = test-cppcheck.sh \
-       test-strrep \
+TESTS = test-strrep \
        test-ptime
 
 check_PROGRAMS = test-strrep test-ptime
@@ -26,3 +25,6 @@ test_ptime_SOURCES = \
        $(top_builddir)/src/ptime.c
 test_ptime_CFLAGS = -I$(top_srcdir)/src
 
+if CPPCHECK
+TESTS += test-cppcheck.sh
+endif
\ No newline at end of file