ignore warning to avoid compilation failures due to removal of GtkAction in gtk+3.10
[ptask.git] / src / Makefile.am
index 84f2093..e89e1fb 100644 (file)
@@ -3,7 +3,7 @@ SUBDIRS=glade
 # -export-dynamic is need for defining handlers in the glade file.
 AM_LDFLAGS = -Wl,--as-needed  -export-dynamic
 
-AM_CPPFLAGS = -Wall -Werror $(GTK_CFLAGS) $(JSON_CFLAGS)
+AM_CPPFLAGS = -Wall $(GTK_CFLAGS) $(JSON_CFLAGS)
 
 DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
 
@@ -11,13 +11,20 @@ LIBS = $(JSON_LIBS) $(GTK_LIBS)
 
 bin_PROGRAMS = ptask
 
-ptask_SOURCES = main.c \
+ptask_SOURCES = list.c list.h \
        log.c log.h \
+       main.c \
        note.c note.h \
+       pio.c pio.h \
        pstr.c pstr.h \
        ptime.c ptime.h \
+       settings.c settings.h \
        tw.c tw.h \
-       ui.c ui.h
+       ui.c ui.h \
+       ui_newtask_diag.c ui_newtask_diag.h \
+       ui_projecttree.c ui_projecttree.h \
+       ui_taskpanel.c ui_taskpanel.h \
+       ui_tasktree.c ui_tasktree.h
 
 dist_man_MANS = ptask.1