(no commit message)
[ptask.git] / tests / Makefile.am
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644 (file)
index 0000000..93032d6
--- /dev/null
@@ -0,0 +1,12 @@
+check-local: checkpatch.pl
+       find $(top_srcdir)/src -name \*.c -exec $(srcdir)/checkpatch.pl --ignore SPLIT_STRING --show-types -q --no-tree  -emacs -f {} \;
+       find $(top_srcdir)/src -name \*.h -exec $(srcdir)/checkpatch.pl --ignore SPLIT_STRING --show-types -q --no-tree  -emacs -f {} \;
+
+EXTRA_DIST = checkpatch.pl \
+       test-cppcheck.sh
+
+TESTS=
+
+if CPPCHECK
+TESTS += test-cppcheck.sh
+endif
\ No newline at end of file