worked on notes directory setting
[ptask.git] / src / Makefile.am
index db90364..bb1cbfc 100644 (file)
@@ -11,11 +11,20 @@ LIBS = $(JSON_LIBS) $(GTK_LIBS)
 
 bin_PROGRAMS = ptask
 
-ptask_SOURCES = main.c \
+ptask_SOURCES = list.c list.h \
        log.c log.h \
+       main.c \
        note.c note.h \
+       pio.c pio.h \
+       pstr.c pstr.h \
        ptime.c ptime.h \
-       tw.c tw.h
+       settings.c settings.h \
+       tw.c tw.h \
+       ui.c ui.h \
+       ui_newtask_diag.c ui_newtask_diag.h \
+       ui_projecttree.c ui_projecttree.h \
+       ui_taskpanel.c ui_taskpanel.h \
+       ui_tasktree.c ui_tasktree.h
 
 dist_man_MANS = ptask.1
 
@@ -23,3 +32,7 @@ ptask.1: main.c $(top_srcdir)/configure.ac
        $(MAKE) $(AM_MAKEFLAGS) ptask$(EXEEXT)
        help2man -N --name="GTk+ Task application" --output=ptask.1 ./ptask$(EXEEXT)
 
+gsettings_SCHEMAS=ptask.gschema.xml
+EXTRA_DIST=$(gsettings_SCHEMAS)
+
+@GSETTINGS_RULES@