added
[www.git] / www / psensor / build_debian_pkg.html
diff --git a/www/psensor/build_debian_pkg.html b/www/psensor/build_debian_pkg.html
new file mode 100644 (file)
index 0000000..9982389
--- /dev/null
@@ -0,0 +1,148 @@
+<!DOCTYPE html>
+<html lang="en">
+<head>
+<meta charset="UTF-8">
+<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge"><![endif]-->
+<meta name="viewport" content="width=device-width, initial-scale=1.0">
+<meta name="generator" content="Asciidoctor 1.5.4">
+<title>How to build the Debian package of psensor from GIT</title>
+<link rel="stylesheet" href="./../style.css">
+<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.5.0/css/font-awesome.min.css">
+<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script>
+<script src="nav.js"></script>
+<script src="https://apis.google.com/js/platform.js" async defer>
+</script>
+</head>
+<body class="article">
+<div id="header">
+<h1>How to build the Debian package of <code>psensor</code> from GIT</h1>
+</div>
+<div id="content">
+<div id="preamble">
+<div class="sectionbody">
+<div class="paragraph">
+<p>This document is explaining step by step how to build the Debian
+package of psensor directly from the GIT repository.</p>
+</div>
+</div>
+</div>
+<div class="sect1">
+<h2 id="_build_the_debian_package">Build the Debian package</h2>
+<div class="sectionbody">
+<div class="paragraph">
+<p>Install <code>git-buildpackage</code>:</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>sudo apt-get install git-buildpackage</pre>
+</div>
+</div>
+<div class="paragraph">
+<p>Install all build dependencies (you can get it from
+the variable <code>Build-depends</code> of the file <code>debian/control</code>):</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>sudo apt-get install ...</pre>
+</div>
+</div>
+<div class="paragraph">
+<p>Checkout the source of <code>psensor</code> and its packaging:</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>git clone https://git.wpitchoune.net/psensor-pkg-debian.git</pre>
+</div>
+</div>
+<div class="paragraph">
+<p>Build the Debian package:</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>cd psensor-pkg-debian.git
+git-buildpackage</pre>
+</div>
+</div>
+</div>
+</div>
+<div class="sect1">
+<h2 id="_build_to_another_debian_distribution">Build to another Debian distribution</h2>
+<div class="sectionbody">
+<div class="paragraph">
+<p><code>pbuilder</code> can be used to build <code>psensor</code> to another Debian
+distribution than the one used by the build machine.</p>
+</div>
+<div class="paragraph">
+<p>Installation of <code>pbuilder</code>:</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>apt-get install pbuilder qemu-user-static</pre>
+</div>
+</div>
+<div class="paragraph">
+<p>Create the distribution image:</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>git-pbuilder create --config raspbian.pbuilderrc</pre>
+</div>
+</div>
+<div class="paragraph">
+<p>The variable <code>DISTRIBUTION</code> in the configuration file is specifying
+the distribution target of the build. It might be useful for
+example to check the compilation on the 'testing' flavor of <code>Debian</code>.</p>
+</div>
+<div class="paragraph">
+<p>See a configuration example for <code>Raspbian</code>:
+<a href="raspbian.pbuilderrc">raspbian</a>.</p>
+</div>
+<div class="paragraph">
+<p>To update the image:</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>git-pbuilder update</pre>
+</div>
+</div>
+<div class="paragraph">
+<p>Checkout the source of <code>psensor</code> and its packaging:</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>git clone https://git.wpitchoune.net/psensor-pkg-debian.git</pre>
+</div>
+</div>
+<div class="paragraph">
+<p>And finally, build the <code>Debian</code> package:</p>
+</div>
+<div class="listingblock">
+<div class="content">
+<pre>git-buildpackage --git-pbuilder</pre>
+</div>
+</div>
+</div>
+</div>
+<div class="sect1">
+<h2 id="_references">References</h2>
+<div class="sectionbody">
+<div class="ulist">
+<ul>
+<li>
+<p><a href="https://wiki.debian.org/git-pbuilder" class="bare">https://wiki.debian.org/git-pbuilder</a></p>
+</li>
+<li>
+<p><a href="https://www.debian.org/doc/manuals/maint-guide/build.en.html" class="bare">https://www.debian.org/doc/manuals/maint-guide/build.en.html</a></p>
+</li>
+</ul>
+</div>
+</div>
+</div>
+</div>
+<div id="footer">
+<div id="footer-text">
+Last updated 2017-01-29 00:41:01 CET
+</div>
+</div>
+</body>
+</html>
\ No newline at end of file