avoid to use cpp in code
[psensor.git] / src / Makefile.am
index 2d9c77c..7f7749c 100644 (file)
@@ -24,7 +24,7 @@ LIBS = \
        lib/libpsensor.a \
        $(GTK_LIBS)\
        $(PTHREAD_LIBS)\
-       $(SENSORS_LIBS)
+       $(SENSORS_LIBS) -lm
 
 if GTK
 if X11
@@ -44,6 +44,7 @@ psensor_SOURCES = \
        ui_appindicator.h \
        ui_color.h ui_color.c \
        ui_graph.h ui_graph.c \
+       ui_notify.h \
        ui_pref.h ui_pref.c \
        ui_sensorlist.h ui_sensorlist.c \
        ui_sensorpref.h ui_sensorpref.c \
@@ -56,7 +57,7 @@ LIBS += $(GTOP_LIBS)
 endif
 
 if LIBNOTIFY
-psensor_SOURCES += ui_notify.h ui_notify.c
+psensor_SOURCES += ui_notify.c
 LIBS += $(LIBNOTIFY_LIBS)
 AM_CPPFLAGS += $(LIBNOTIFY_CFLAGS)
 endif
@@ -84,6 +85,10 @@ AM_CPPFLAGS += $(ATASMART_CFLAGS)
 LIBS += $(ATASMART_LIBS)
 endif
 
+if LIBUDISKS2
+LIBS += $(LIBUDISKS2_LIBS)
+endif
+
 if UNITY
 psensor_SOURCES += ui_unity.h ui_unity.c
 AM_CPPFLAGS += $(UNITY_CFLAGS)