avoid to fail on error due to deprecation of GtkStatusIcon
[psensor.git] / src / Makefile.am
index 34741e8..7611095 100644 (file)
@@ -9,7 +9,7 @@ SUBDIRS += server
 endif
 endif
 
-AM_CPPFLAGS =-Wall -Werror \
+AM_CPPFLAGS =-Wall \
        -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
        -DDATADIR=\""$(datadir)"\"\
        -DPSENSOR_DESKTOP_FILE=\""psensor.desktop"\"\
@@ -84,6 +84,10 @@ AM_CPPFLAGS += $(ATASMART_CFLAGS)
 LIBS += $(ATASMART_LIBS)
 endif
 
+if LIBUDISKS2
+LIBS += $(LIBUDISKS2_LIBS)
+endif
+
 if UNITY
 psensor_SOURCES += ui_unity.h ui_unity.c
 AM_CPPFLAGS += $(UNITY_CFLAGS)