v0.0.6
[ppastats.git] / trunk / configure.ac
diff --git a/trunk/configure.ac b/trunk/configure.ac
new file mode 100644 (file)
index 0000000..f9b1070
--- /dev/null
@@ -0,0 +1,42 @@
+#                                               -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.64])
+AC_INIT([ppastats], [0.0.7],[jeanfi@gmail.com],[ppastats],[http://wpitchoune.net/ppastats])
+
+AM_INIT_AUTOMAKE([-Wall -Werror gnu])
+
+AC_CONFIG_SRCDIR([src/main.c])
+AC_CONFIG_HEADERS([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+AM_PROG_CC_C_O
+
+# Checks lib build
+AC_PROG_RANLIB
+
+# Checks for header files.
+AC_PATH_X
+AC_CHECK_HEADERS([getopt.h stdio.h stdlib.h string.h sys/stat.h sys/time.h sys/types.h time.h])
+
+# Checks CURL 
+PKG_CHECK_MODULES(CURL, libcurl )
+AC_SUBST(CURL_CFLAGS)
+AC_SUBST(CURL_LIBS)
+
+# Checks JSON 
+PKG_CHECK_MODULES(JSON, json )
+AC_SUBST(JSON_CFLAGS)
+AC_SUBST(JSON_LIBS)
+
+AC_CONFIG_FILES([
+ Makefile
+ src/Makefile
+ tests/Makefile
+ www/Makefile
+])
+
+AC_CHECK_PROGS([HELP2MAN], [help2man])
+
+AC_OUTPUT