next release will be 1.3.3
[ppastats.git] / tests / Makefile.am
index c3afa6a..e80d69c 100644 (file)
@@ -4,11 +4,14 @@ check-local: checkpatch.pl
 
 EXTRA_DIST = \
        checkpatch.pl \
-       test_strrep.c
+       test-cppcheck.sh \
+       test_strrep.c \
+       test_ptime.c
 
-TESTS = test-strrep
+TESTS = test-strrep \
+       test-ptime
 
-check_PROGRAMS = test-strrep
+check_PROGRAMS = test-strrep test-ptime
 
 test_strrep_SOURCES = \
        test_strrep.c \
@@ -16,3 +19,12 @@ test_strrep_SOURCES = \
        $(top_builddir)/src/pstr.c
 test_strrep_CFLAGS = -I$(top_srcdir)/src
 
+test_ptime_SOURCES = \
+       test_ptime.c \
+       $(top_builddir)/src/ptime.h \
+       $(top_builddir)/src/ptime.c
+test_ptime_CFLAGS = -I$(top_srcdir)/src
+
+if CPPCHECK
+TESTS += test-cppcheck.sh
+endif
\ No newline at end of file