next release will be 1.3.3
[ppastats.git] / tests / Makefile.am
index 466b5be..e80d69c 100644 (file)
@@ -1,17 +1,30 @@
 check-local: checkpatch.pl
        find $(top_srcdir)/src -name \*.c -exec $(srcdir)/checkpatch.pl --show-types -q --no-tree  -emacs -f {} \;
-       find $(top_srcdir)/src -name \*.h -exec $(srcdir)/checkpatch.pl --show-types -q --no-tree  -emacs -f {} \;
+       find $(top_srcdir)/src -name \*.h -exec $(srcdir)/checkpatch.pl --ignore NEW_TYPEDEFS --show-types -q --no-tree  -emacs -f {} \;
 
 EXTRA_DIST = \
        checkpatch.pl \
-       test_strrep.c
+       test-cppcheck.sh \
+       test_strrep.c \
+       test_ptime.c
 
-check_PROGRAMS = test-strrep
+TESTS = test-strrep \
+       test-ptime
 
-AM_CPPFLAGS = -pedantic -Werror
+check_PROGRAMS = test-strrep test-ptime
 
 test_strrep_SOURCES = \
        test_strrep.c \
-       ../src/str.c
+       $(top_builddir)/src/pstr.h \
+       $(top_builddir)/src/pstr.c
+test_strrep_CFLAGS = -I$(top_srcdir)/src
+
+test_ptime_SOURCES = \
+       test_ptime.c \
+       $(top_builddir)/src/ptime.h \
+       $(top_builddir)/src/ptime.c
+test_ptime_CFLAGS = -I$(top_srcdir)/src
 
-TESTS = test-strrep
+if CPPCHECK
+TESTS += test-cppcheck.sh
+endif
\ No newline at end of file