merged plib
[ppastats.git] / tests / Makefile.am
index c3afa6a..cb62afe 100644 (file)
@@ -4,11 +4,13 @@ check-local: checkpatch.pl
 
 EXTRA_DIST = \
        checkpatch.pl \
-       test_strrep.c
+       test_strrep.c \
+       test_ptime.c
 
-TESTS = test-strrep
+TESTS = test-strrep \
+       test-ptime
 
-check_PROGRAMS = test-strrep
+check_PROGRAMS = test-strrep test-ptime
 
 test_strrep_SOURCES = \
        test_strrep.c \
@@ -16,3 +18,9 @@ test_strrep_SOURCES = \
        $(top_builddir)/src/pstr.c
 test_strrep_CFLAGS = -I$(top_srcdir)/src
 
+test_ptime_SOURCES = \
+       test_ptime.c \
+       $(top_builddir)/src/ptime.h \
+       $(top_builddir)/src/ptime.c
+test_ptime_CFLAGS = -I$(top_srcdir)/src
+