merged from plib
[ppastats.git] / tests / Makefile.am
index 0a5f3ef..c3afa6a 100644 (file)
@@ -6,12 +6,13 @@ EXTRA_DIST = \
        checkpatch.pl \
        test_strrep.c
 
-check_PROGRAMS = test-strrep
+TESTS = test-strrep
 
-AM_CPPFLAGS = -pedantic -Werror
+check_PROGRAMS = test-strrep
 
 test_strrep_SOURCES = \
        test_strrep.c \
-       ../src/str.c
+       $(top_builddir)/src/pstr.h \
+       $(top_builddir)/src/pstr.c
+test_strrep_CFLAGS = -I$(top_srcdir)/src
 
-TESTS = test-strrep