added inlt support
[ppastats.git] / src / Makefile.am
index a662a5f..e19e20a 100644 (file)
@@ -1,13 +1,17 @@
 
-AM_CPPFLAGS = -Wall -std=gnu99 -Werror \
+AM_CPPFLAGS = -Wall -std=gnu99 -Werror\
+        -DDEFAULT_WWW_DIR=\""$(pkgdatadir)/www"\"\
        $(CURL_CFLAGS) $(JSON_CFLAGS)
 
 LIBS += $(CURL_LIBS) $(JSON_LIBS)
 
+DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
 bin_PROGRAMS = ppastats
 ppastats_SOURCES = \
        cache.h cache.c\
        html.h html.c\
+       io.h io.c\
        list.h list.c\
        lp.h lp.c\
        lp_json.h lp_json.c\
@@ -18,6 +22,7 @@ ppastats_SOURCES = \
 dist_man_MANS = ppastats.1
 
 ppastats.1: main.c $(top_srcdir)/configure.ac
-       $(MAKE) $(AM_MAKEFLAGS) ppastats$(EXEEXT)
-       help2man -N --name="PPA Statistics command line tool" --output=ppastats.1 ./ppastats$(EXEEXT)
-
+       if ! test -z "$(HELP2MAN)"; then \
+        $(MAKE) $(AM_MAKEFLAGS) ppastats$(EXEEXT); \
+        help2man -N --name="PPA Statistics command line tool" --output=ppastats.1 ./ppastats$(EXEEXT); \
+       fi;