use file cache for distros
[ppastats.git] / src / Makefile.am
index fb3ce06..5add147 100644 (file)
@@ -5,17 +5,22 @@ AM_CPPFLAGS = -Wall -std=gnu99 -Werror\
 
 LIBS += $(CURL_LIBS) $(JSON_LIBS)
 
+DEFS = -DPACKAGE_DATA_DIR=\"$(pkgdatadir)\" -DLOCALEDIR=\"$(localedir)\" @DEFS@
+
 bin_PROGRAMS = ppastats
 ppastats_SOURCES = \
        cache.h cache.c\
+       fcache.h fcache.c\
        html.h html.c\
        io.h io.c\
        list.h list.c\
+       log.h log.c\
        lp.h lp.c\
        lp_json.h lp_json.c\
        lp_ws.h lp_ws.c\
        main.c\
-       ppastats.h ppastats.c
+       ppastats.h ppastats.c\
+       str.h str.c
 
 dist_man_MANS = ppastats.1