help2man optional
[ppastats.git] / src / Makefile.am
index 4b42165..bcb15aa 100644 (file)
@@ -19,6 +19,7 @@ ppastats_SOURCES = \
 dist_man_MANS = ppastats.1
 
 ppastats.1: main.c $(top_srcdir)/configure.ac
-       $(MAKE) $(AM_MAKEFLAGS) ppastats$(EXEEXT)
-       help2man -N --name="PPA Statistics command line tool" --output=ppastats.1 ./ppastats$(EXEEXT)
-
+       if ! test -z "$(HELP2MAN)"; then \
+        $(MAKE) $(AM_MAKEFLAGS) ppastats$(EXEEXT); \
+        help2man -N --name="PPA Statistics command line tool" --output=ppastats.1 ./ppastats$(EXEEXT); \
+       fi;